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The materials used 
in this Tutorial are:

• V-SFT ver.5

• MONITOUCH V806 color type (QVGA)

• ���:  General Modbus RTU driver



1. Preparation

1. Starting V-SFT
“Edit Model Selection” to “Comm. Parameter” setting

2. Outlook of Ver.5 screen
Outlook of Ver.5 and customizing

3. Drawing lines and rectangles

4. Placing “Text”

5. Saving screen data

6. Transferring screen data to MONITOUCH
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1. Starting V-SFT “Edit Model Selection” to “Comm. Parameter” setting

1) Start V-SFT

3) PLC select

(a)

(c)
(b)

(a) Device Connected�PLC
(b) Maker�Others
(c) Series�Modbus RTU
> Click [OK]

Go to [File] > [New] OR Click [New] icon

2) Edit Model Selection

1-2
Select [V806T/C] > Click [OK]



4) Device connection setting [PLC1]

(b)
(a)

(c)
(d)
(e)

(a)Signal Level
(b)Baudrate
(c)Data Length
(d)Stop Bit
(e)Parity
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5) Read/Write Area
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2. Outlook of ver.5 screen Outlook of ver.5 and customizing

(a)
(d)

(b)

(c)

(a) Project View (c) Parts List
(d) Catalog View1-5(b) Item View



1) Move View 2) Fix View

Double-click

Drag

Double-click the top of the view 
OR drag 

Double-click the top of the view
OR [Ctrl]+ drag 1-6



3) How to display “Toolbar”

(a)

(b)

(c)

(d)

4) Customizing “Toolbar”

[Tool] > [Customize][View] > [Toolbar] > Select items to display

(a) Standard
(b) Edit

(c) Draw

(a)
(b)
(c)
(d)

(d) Parts Mini
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3. Drawing lines and rectangles
3) Drawing a line1) Select line color

Click the arrow next to “Pen” icon > Select line color Click [Straight Line] icon > Drag the cursor

4) Cancel the drawing mode2) Select line type

Click the arrow next to “Line” icon > Select line type Right-click OR Click anywhere on the screen

1-8



3. Drawing lines and rectangles
3) Select paint color1) Select frame type

Click the arrow next to [Paint] icon
> Select paint color

Click the arrow next to [Frame Type] icon
> Select frame type

4) Drawing a rectangle2) Select line color and line type

Click [Rectangle] icon > Select “Rectangle”
Drag the cursor from the start-point to the 
end-point

Select line color and line type

1-9



4. Placing “Text”
1) Property Setting 3) Making text area

(a) (b)

a) Color
b) Paint / Background color

Drag from the start-point 
to the end-point

Blinking cursor 
appears

Select the color for text and background

4) Edit text2) Select [Text]

Screen 1

Click [Text] icon > Select [Text] Edit the text in text area
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5. Saving screen data
2) Naming file and selecting “Save in”1-1) Save

3) Created files and their extension 1-2) Save As…
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6. Transferring screen data
3) COM port setting1) Necessary tools

Cable: V-CP
(Dsub9M-RJ45)

2) Connection 4) Transfer
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2.    How can I place lamps and switches?

Completed screen Lamp lights up and off according to bit 
memory’s ON/OFF status.

2-1

Function used : Lamp�by Wizard�
Switch (by Wizard�

Switch controls PLC bit to ON/OFF.

Also, wide variety of switch functions 
such as displaying pop-up window, 
switching the screens are available.

Bit ONBit ONLamp lights up

Bit ONBit ON



1) Start “Wizard”

Select parts list > Select part > Click [Next]

[Catalog View] > [Wizard]tab > [Lamp]

2) [Select Part]

3) [Style Setting]

Set lamp memory > Click [Next]

4) [Memory Setting]

Click [Next]
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5)[Input Text] 7) Multi-copy

(a)

(b)
(b)

(a)

Enter text on lamp > Click [Place]

6) Placing a lamp 8) Placing multiple lamps

Multi-copy completedPlace a lamp by dragging it
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1) Start “Wizard” 3) [Style Setting]

Click [Next][Catalog View] > [Wizard]tab > [Switch]

4) [Function Select]2) [Select Part]

Select parts list > Select part > Click [Next] Select [Standard Switch] > Click [Next]
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5) [Memory Setting] 7) Multi-copy

Placing 4 switches by multi-copy and copySet switch memory > Click [Next]

8) Setting for Output Action

2-5

(b)

(a)

6) [Input Text]

Enter text on switch > Click [Place]



Operation CheckOperation Check

Check the function of each switch with different output action.
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3.    How can I display the value in PLC register 
in graph?

Completed Screen

Visualizing numeric data in PLC register 
in graph format.

Graph can improve the visibility even 
more by using “Alarm” function to 
change the color of graph.

In this chapter, we will place a bar graph, 
a panel meter and a statistic pie graph.

Function used: Bar Graph (by Wizard)
Panel Meter (by Wizard)
Statistic Pie Graph (by Wizard)
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2) [Select Part]

3) [Memory Setting]

4) [Color Setting]

Set graph memory > Click [Next]

1) Start “Wizard”

[Catalog View] > [Wizard] tab> [Graph] > [Bar Graph]

Click [Next]Select parts list > Select part > Click [Next]
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7) Separate Color Display5) [Alarm Setting]

(a)

(b)

(c)

Set alarm > Click [Place]
(a) Upper Limit: 70 (Red)
(b) Lower Limit: 30 (Yellow)

6) Copy bar graph

Copying the graph by copy & paste
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2) [Select Part]

3) [Memory Setting]

4) [Color Setting]

Set panel meter memory > Click [Next]

1) Start “Wizard”

[Catalog View] > [Wizard] tab > [Graph] > [Panel Meter]

Select parts list > select part > Click [Next] Change color for “Indicator” > Click [Next]

3-4



5) [Alarm Setting]

(b)

(a)

(c)

Use Alarm > Click [Place]

6) Placing a panel meter
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Place % display > Click [Place]

2) [Select Part]

Select parts list > Select part > Click [Next]

3) [Memory Setting]

4) [Image]

1) Start “Wizard”

[Catalog View] > [Wizard] tab > [Graph]
> [Statistic Pie Graph]

Set  the top address of statistic pie graph memory 
> Click [Next]
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5) Placing a statistic pie graph 7) % display

8) Placing % displays6) Link Cancel

Right-click on graph > Select [Link Cancel]
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Operation Check

Check how each graph displays by entering the value in PLC memory.
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4. How can I display the value in PLC 
memory numerically?

Completed screen

Displaying the value in PLC memory 
as numerical display on MONITOUCH.

Alarm setting enables the display in 
different color, e.g. when exceeding a 
normal range.

Function used: Numerical Display (by Wizard)
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2) [Select part] 4) [Mem./Dis. Setting]

[Catalog View] > [Wizard] tab > [Data Display]
> [Num. Display]

3) [Function Select]1) Start “Wizard”

Select “Num. Display” > Click [Next]

[Set the Memory] > Click [Next]Select part > [     Place Multiple Parts] > Click [Next]
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5) [Char. Prof. Setting] 7) [Place Multiple Parts]

4-3

6) [Detail Setting]

Set [Quantity] and [Inc. Memory] > Click [OK]

[ Use Alarm] > [Max]/[Min] setting > Click [Place]

8) Num. Display and text placing

Click [Next]

Place part > Place text



Operation Check

Check the dipaly on MONITOUCH by changing the value in PLC memory 4 00300 to 4 00304.

4 00300

4 00301

4 00302

4 00303

4 00304
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5. How can I change the value in PLC memory 
from MONITOUCH?

Completed screen

Pop-up
Keypad
appears

PopPop--upup
KeypadKeypad
appearsappears

Entering the value directly to the PLC 
memory by using keypad on 
MONITOUCH.

4 00400

4 00401

4 00402

Function used: Entry Mode (by Wizard)
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2) [Select part]

1) Start “Wizard”

[Catalog View] > [Wizard] tab > [Data Display]
> [Num. Display]

3) [Function Select]

Select “Entry Target” > Click [Next]

Select part > [     Place Multiple Parts] > Click [Next]
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4-1) [Input Setting] 5) [Mem./Dis. Setting]

“Display only when Necessary” > “Register” Set the Memory > Click [Next]

6) [Char. Prop. Setting]4-2) [Input Setting] (“Select” button)

Click “Select” button > Select keypad part 
> Click [Next]

Click [Next]
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9) Place parts

Place parts on the screen

7) [ Detail Setting ]

[ Use Alarm] > [Max]/[Min] setting > Click [Place]

Set [Quantity] > [OK]

(a)

5-4

(b)

(a) Quantity X: 1
Quantity Y: 5

(b)     Numerical 
Data Memory : 1

10) Position adjustment and text placement

Adjust the parts position > Place texts



Operation Check

Let’s try to enter the value using a keypad.

4 00400

4 00401

4 00402

4 00403

4 00404
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6. How can I display the message?

Completed screen

Function used: Comment Display

Creating this part
Registering the messages beforehand 
and display them according to the 
value in PLC memory.

1) Linking the message and 
PLC memory beforehand…

When 4 00500=0 When 4 00500=3

2) Enter the value to PLC memory and the 
corresponding message is prompted.
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2) Selecting “Group No.”1) Project View����

Group “0”> Click [OK]

3) Open [Comment Edit] dialog

[Project View] > [Screen] tab > [Comment]
> [New]

[Comment Edit] dialog is prompted.
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4) Edit Comment 4-1) Editing “Comment” as follows:

Comment 1: V712iSD Comment 3� V706MD
SVGA 800x600 QVGA  320x240
32k Color MONO 
CF Card CF Card (Option)
SRAM  64kbyte SRAM  128kbyte 
Video/Sound Ethernet (Option)
Ethernet CE/UL/cUL
CE/UL/cUL Comment 4:    V606eM20

Comment 2: V710CD QVGA 320x240 
VGA  640x480 MONO
128 Color SRAM 128kbyte
CF Card CE/UL/cUL
SRAM  64kbyte Comment 5: V606eM10
CE/UL/cUL QVGA 320x240

MONO
CE/UL/cUL

(a)

4-2) [Font] setting  (Click (a))

(b)

(c) (d) (e)

(b) Color

(c) Bold

(d) Italic

(e) Transparent

Edit “Comment”
> Click [X] button to close the dialog
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7) “Display Area” dialog5) Place “Comment Display”

[Catalog View] > [Message] > [Comment Display] 
> Drag

Double-click “Display Area”
> [Display Area] dialog prompted.

6-4

6) “Comment Display” setting

Double-click the icon
> [Comment Display] 
dialog prompted

Select [Word Designation]
> Set [Command Memory]
Command Memory : 4 00500

Change [Color]



9) Adjust “Display Area” size8) Change “Grid”

Adjust the area to include 8 linesRight-click > [Grid]> [Grid Setting]> [OK]

(a)

(b)

(a) ON Grid
(b) Grid Type:  1-Byte
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Operation Check

Check if the corresponding message is displayed by changing the value in 
PLC memory 4 00500.

6-6



7. How can I display errors in their  
priority order?

Displaying the error message in their priority 
order, not in chronological order.
When an alarm bit is set ON, corresponding 
error message is displayed from the top of the 
display area. Error message which has more 
priority comes to the top of the display area. 
When an error is corrected(alarm bit OFF), the 
corresponding error message disappears.

This chapter explains how to create the screen 
to display error messages in the upper half and 
sub display for error messages in the lower half 
of the screen.

Completed screen

Function used : Bit Order Alarming
Alarm Sub Display
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1) Select from [Catalog View] 2) Placing “Bit Order Alarming” parts 

[Bit Order Alarming] > Click and drag it to the screen

[Catalog View] > [Parts]tab > [Alarm]
> [Bit Order Alarming]
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5) Adjust “Display Area” size3) Link Cancel

Right-click > [Change Part]> [Link Cancel]
Handle display > Cancel handle display by a click

Adjust the area to include four lines

6) Detail setting4) Changing “Grid”

(a)

(b)

Double-click the icon on the top left of the 
area
> [Bit Order Alarming] dialog opens

Right-click > [Grid]> [Grid Setting]> [OK]

(a) ON Grid
(b) Grid Type:  1-Byte 7-3



(a)

(b)

(c)
(d)

(e)

7) [Main] tab setting 8) Message Edit

(a) Memory: PLC  1 00100
(b) Start Message:   G. No.  0,  No.0
(c) Executing Relays:  5
(d) No. of Lines per Relay: 1
(e) Action Area:  Display Area

Edit 5 messages starting from 00000
> Click      after completion

--- Message to edit ---
00000 : Error 1
00001 : Error 2
00002 : Error 3
00003 : Error 4
00004 : Error 5

After completing, click [Open…]
> [Message] dialog appears
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9) [Sub-action] tab setting 11) Display “Preview”

(a) Type:  Sub-Display

10) [Style] tab setting

[View]> [Display Environment]
> [Display Message]
>  [OK]

(a) Enlarge:  X – 1, Y – 2
After completing setting, click 
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12) Place “Alarm Sub Display” parts 13) Link Cancel

Right-click > [Change Part]> [Link Cancel]
Handle display > Cancel handle display by a click

14) Adjust “Display Area” size

[Alarm] > [Alarm Sub Display]
> Click and drag it to the screen Adjust the area size to include four lines
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(a)
(b)

(c) Set “1” to [Message Group] in the right dialog
> Click “Edit”
> Register 5 multi-line messages in Group 1

> Click [Registration Complete] and       after 
editing messages
> Back to “Page Block Edit”

00256: a

00257: aa

00258: aaa

00259: aaaa

00269: aaaaa

00276: e

00277: ee

00278: eee

00279: eeee

00280: eeeee

15) Detail setting 17-1) Page Block Edit�1. Register messages�

Double-click the icon on the top left of “Display Area”

16) [Main]tab setting

(a) Link ID:  0
(b) Block:  Page Block
(c) Block No.:  0

After completing setting, click [Open…]
> “Page Block Edit” dialog appears 7-7



17-2) Page Block Edit �2. Creating “Page Block”�

Block 1

Block 2

Block 3

Block 4

Block Block 
00

Page Block setting are;

Block 0:  Message G1: Line 0 - 4
Block 1:  Message G1: Line 5 - 9
Block 2:  Message G1: Line 10 - 14
Block 3:  Message G1: Line 15 - 19
Block 4:  Message G1: Line 20 - 24

18) Completed screenMake sure “0” is selected for [Block No.] on the left 
hand side
> Select the start message and end message to 
include in Block 0 (Click the start message and the 
end message with “Shift” key held down�
> Click [Register] button in the middle
> Change [Block No.] from “0” to “1”
> Select the start message and end message to 
include in Block 1
> Create 5 Blocks (to No. 4) in the same way as 
above
After completing, click at the top right corner
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Operation Check

Check if the corresponding message is displayed by setting error bits 
(starting from 1 00100�.

Error message byError message by

Bit Order AlarmingBit Order Alarming

SubSub--display by Alarm display by Alarm 
SubSub--display with Page display with Page 
Block Block 
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8. How can I display the error history? 

Completed screen
Sampling error messages and time stamps 
according to bit action and display on the 
screen as error history.

In this chapter, four error bits are monitored.

ON OFF

Monitor alarm bit statusLog and display error 
history

1 00017

1 00018

1 00019

Function used �Alarm Tracking
�by Wizard�
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8-2

[#6[3D 320*240]] > [Next]

[Catalog View] > [Wizard] tab > [Alarm] > 
[Alarm Tracking]

2) [Select Part]

3) [Style Setting]

[Select a switch] > [Next]

4) [Select Part to Append]

[Set the character property] > [Next]

1) Start “Wizard”



5) [Buffering Area Select]

[Item List] > Select [0] > [Next]

6) [Buffering Area Setting]

(a)
(b)

(a) [Specify Top Memory]  1 00017
(b) [Word Count] : 1 word

[Specify Top Memory] > [Word Count] > [Next]
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7) [Storing Target Setting]

(a) [No. of Saved Data] : 1000
(b) [Specify the storing target] : SRAM

(a)

(b)
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8) [Resister Messages] 9) [Error Display Setting]

(a)

(b)

(c)

[G No.]> Double click “Message” column.

[Select the history display] > [Select the display 
format for date and time] > [Next]

8-5

Edir Message [2]

[Place]



11) Place “Alarm Tracking” parts

12) Place a format switch
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Preparation for Operation Check

Initial format of SRAM area

SRAM���������
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Operation Check

Set error bits and see how the error history is displayed.
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99.. How can I display the sampled data How can I display the sampled data 
in line graph?in line graph?

Completed screenCompleted screen Display the periodically sampled numeric data 
in line graph format. The sampled data is 
stored in the area called “Buffering Area” in 
MONITOUCH, so you can see the data 
history as well. 

In this chapter, we will monitor 2 words of 
PLC memory addresses(4 00600 and 4 
00601) then display the history in line graph.

Function used : Trend Sampling (by Wizard)

Monitor PLC 
memory

Store the data
Display in line graph
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1) Start “Wizard”

2) [Select Part]

[Catalog View] > [Wizard]tab
> [Trend Graph] > [Trend Sampling]

Select “#3 [3D 320*240 Metal]” > [Next]
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5) [Buffering Area Setting]3) [Select Part to Append]

(a)

(b)
(c)

(d)

Click [Next]

4) [Buffering Area Select] [Buffering Area Setting] details

a) [Specify a sampling method]: Constant Sampling
b) [     Specify Top Memory]: PLC memory 4 00600
c) [Word Count]: 2 (Word)
d) [Monitoring Time]: 5 (sec)
e)      Start Bit
> [Next]

Select “1” for “Item List” > Click [Next]
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6) [Storage Target Setting] 8) [CSV Output Format (Attribute setting)]

Use a Calculation Operation
Use Start Bit

7) [Buffering Area Function]

[X Axis Data Points]: 10 > [Next]

(a)

(b)

10) [a graph image]

(a) [No. of Saved Data]  : 1000
(b) [Specifying the storing target] : SRAM   > [Next]

9) [CSV Format]
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11) [Display Type Setting] [Graph No.1]

(a)

(b) (c)

[Graph No.0]

[Graph No.0] and [Graph No.1] setting
> [Next]

[Graph No.0] and [Graph No.1] details

(a) [Sampling Buffer Word No.] :
graph No.0 0
graph No.1 1

(b) [Graph Min. (Max.) Value] :
graph No.0 Min. 0

Max. 100
graph No.1 Min. 0

Max. 500
(c) [Line Graph] color : any
> [OK]

(a)

(b)

(c)
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12) [Reference Line Setting]

(a)

(b)

[Reference Line Setting] details

(a) [Set a scale] :
Graph Max.: 10
Graph Min.: 0

(b) [Define the area] : Tick all
Reference Line1 : 9
Reference Line2 : 6
Reference Line3 : 4
Reference Line4 : 1

> [Place]
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Preparation for Operation Check

Initial format of SRAM area

SRAM���������

9-7



Operation Check

Check how the changing values of PLC memory addresses are displayed
with each line graph.

(b)

(a)
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10. How can I display, move and 
transform the graphic?

Completed screen

Display Move and Transform
Bit OFF Set a bit ON Give value to Parameter

Move and transform
the graphic by giving 
value to Parameter

Function used : Graphic Relay Mode
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10-2

[Catalog view] > [Parts] tab > [Graphic]
> [Graphic Relay]

1) Select from [Catalog View] 3) Enlarge the part

Select the part and enlarge by dragging outward

2) Place “Graphic Relay” part 

[Graphic Relay] > Click and drag it to the screen



(a)

(b)
(c)
(d)

(e)

4) “Graphic Relay” setting 5) [Main] tab setting

Double-click the icon on the top left corner

[Main] tab setting

(a) [Memory]:4 00700-00
(b) [Start Graphic]: G No 0 No  0
(c) [No. of Relays]:1
(d) [No. of Parameter Words]:3
(e) [Type]:1-Graphic

Click       after completion
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6) Open [Graphic Library] 8) Draw a circle in [Graphic Library0�0]

[Project view] > [Screen]tab > [Graphic Library]
> [New]

Click “Circle” icon on “Draw” toolbar and draw

7) Select [Graphic Library0�0] 9) Place a circle 

Select “0” to each [Group No.] and [No] 
> Click [OK] 10-4



10) Open [Parameter] dialog

(a)

(b)

(c)

(d)

11) [Parameter Setting] tab setting 

Select the circle > click “Parameter” icon

[Parameter Setting] tab setting

Click      after completion

(a) [Action]: Animation
(b) [Center X]: Increment + 1
(c) [Center Y]: Increment + 2
(d) [Radius]: Increment + 3
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12) Close [Graphic Library] screen

Close [Graphic Library0�0]
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Operation Check

Display, move and transform the graphic.
(3)(1)

Bit 0 of 4 00700 : ON, 4 00701(X axis) : 150,
4 00702 (Y axis) : 40

Bit 0 of 4 00700: OFF

(2) (4)

Bit 0 of 4 00700 : ON, 4 00701(X axis) : 150,
4 00702 (Y axis) : 40, 4 00703 (Radius) : 40

Bit 0 of 4 00700 : ON
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Appendix-1. How can I change the screen to be 
displayed by using a switch?

Completed screen
Screen 1Screen 0

Click the switch.    Screen 1 displayed.

Function used�Switch
Appendix 1-1



Drag

3) Placement of Switch1) Select from [Catalog View]

[Catalog view] > [Parts] tab > [Parts List] Select Switch > Place by dragging

Click to close [Parts List]2) Select from [Parts List]

Select Switch from [Parts List]

(a)
(b)

(a) Switch
(b) #15 [3D-I 2Pattern]

Appendix 1-2



4) Open [Item view]

(a)
(b)

Set the function of Switch under [Main] tab

(c)

6) [Text] tab setting

Input the text to display on Switch
>  Click        of Item view to closeClick the switch that was placed

7) [Text] Placement5) [Main] tab setting

Set up under Main tab

(a) Standard
(b) Screen
(c) Screen No.: 1

Place [Text] on the screen
Appendix 1-3



Operation Check

Let’s shift the display from Screen 0 to Screen 1 by pressing the switch.

������ ������
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Appendix-2. How can I debug on PC?

Screen 1Screen 0

Check the operation by clicking the switch on PC Check the operation by entering some value in PLC memory  

Functions used�Emulator and Simulator
Appendix 2-1



1) Start [Emulator] 3) Press switch 

Click the switch to light the lamp up[File] > [Start Emulator]

2) Operation check of Switch and Lamp 4) Move to Screen 1

Move to Screen 1 with a SwitchSet a mouse by a Switch on [Emulator]
Appendix 2-2



5) Start [Simulator] 6) Enter the value to 4 00200

(a) (b) (c)

(a) Address: Memory list currently used on the Screen No1
(b) Value:     Present value of the memory
(c) Item:       Name of the item, which the memory is used

Confiuration of  [Simulator]

Double-click (b)
Appendix 2-3

[Simulator] automatically starts up when [Emulator] runs

Enter “75”> Click [OK]

7) Operation Check



8-1) Memory Counter Setting 8-3) Memory Counter Setting

Set Memory Counter in 4 00202, 4 00203 and 4 00204Double-click “Value” of 4 00201

(a) Use Memory Counter
(b) Increment : 10
(c) Interval Timer : 10

(a)
(b)
(c)

Click OK after setting

(a) Use Memory Counter
(b) Increment : 15
(c) Interval Timer : 10

4 00202 Write into Memory Setting

(a) Use Memory Counter
(b) Increment : 20
(c) Interval Timer : 10

4 00203 Write into Memory Setting

(a) Use Memory Counter
(b) Increment : 25
(c) Interval Timer : 10

4 00204 Write into Memory Setting

Appendix 2-4

8-2) Memory Counter Setting

4 00201 Write into Memory Setting



9) Start Memory Counter

Click on      mark > Hourglass will be shown

4 002014 00201

4 002024 00202

4 002034 00203

4 002044 0020410) Operation Check

Appendix 2-5



Reference: How to use “Simulator”
Simulator enables you to debug your program on V8 without connecting PLC.
On V-SFT-5

3) Set COM port1) [File] >[Transfer]

4) Transfer screen program and special 
driver

Appendix 2-6

2) Check [Use Simulator]



On V8 unit

3) Press [Setting Finished]1) [Main Menu] > [Simulator]

You will see [Simulator] button only when you 
check [Use Simulator] and download special 
driver to V8.

2) Press [Simulator] to talk to Simulator

Appendix 2-7



Debugging using Simulator

Click [SIM] icon. Run Simulator and test your 
program.

Appendix 2-7
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